ChronoMath, une chronologie des MATHÉMATIQUES
à l'usage des professeurs de mathématiques, des étudiants et des élèves des lycées & collèges

Calcul de la constante d'Euler, version tableur    
 
Version  JavaScript

L'existence de cette constante, notée ici C :

est assez simple à prouver. La série 1 + 1/2 + 1/3 + 1/4 +... + 1/n + ... dite harmonique , est divergente :

Cette divergence est lente. En interprétant le logarithme népérien (noté ln) comme une aire (ci-dessus), la linéarité de l'intégrale permet d'écrire (la zone bleue correspond au membre de gauche de l'encadrement) :

Posons Sn = 1 +1/2 + 1/3 + ... + 1/n. L'encadrement précédent s'écrit alors : Sn - 1 < ln n < Sn - 1/n, soit :

1/n < Sn - ln n < 1

On voit donc que la suite (un) définie par :

est bornée et si elle est convergente, sa limite C vérifie 0 C 1. On pose maintenant :

On a :

un+1 - un = f(n)

L'étude de la fonction f montre qu'elle est strictement négative, croissante et sa limite à l'infini est nulle : on en déduit que la suite (un) décroît et, étant bornée, converge : sa limite est la constante d'Euler notée C.

Pour un calcul sur machine, il nous faut trouver un encadrement de C, afin de s'assurer une convergence non douteuse. Introduisons alors une suite auxiliaire nous amenant à la notion de suites adjacentes :

On a alors vn = un - 1/n. Il est facile de montrer que (vn) converge vers C en croissant, alors que, on vient de le voir, (un) converge vers C en décroissant. Ainsi :

vn < C < un et les suites (un) et (vn) sont alors dites adjacentes :

Suites adjacentes :    
 

On dit que deux suites numériques (un) et (vn) sont adjacentes si, à partir d'un certain rang no, il est assuré que :
  • l'une des deux suites est croissante;
  • l'autre est décroissante;                                 Autres exemples de suites adjacentes
  • la différence un - vn tend vers 0.

Deux telles suites sont convergentes et ont la même limite car l'une est croissante majorée, l'autre décroissante minorée (dès n no).

  L'immense avantage dans un tel cas est de pouvoir obtenir un encadrement de la limite cherchée

Programme avec appel récursif (mode itératif) sur Tableur :

Le tableur, admettant les références circulaires (récursion), est particulièrement efficace dans ce type de calcul. On utilise la technique du drapeau, noté ici d. Pour nommer les cellules, choisir l'item Définir un nom... dans le menu Sélection.

A

B

C

1

compteur

série harmonique

drapeau

2

=SI(d=0;1;k+1)

=SI(d=0;1;B2+1/k)

1

3

suite Un

4

=B2-LN(k)

5

suite Vn

6

=B2-1/k-LN(k)

7

moyenne

erreur

8

=(B4+B6)/2

=(B4-B6)/2

Exemple d'exécution :
 

compteur

série harmonique

drapeau

17384
10,34054994864120
1

suite Un

0,57724442670494

suite Vn

0,57718690254479

moyenne

erreur

0,57721566462487
2,88E-05

Les divergence et croissance lentes de la série harmonique et du logarithme népérien impliquent la lente convergence vers C. De plus, il se greffe dans le calcul de la somme (B2) des erreurs d'arrondi difficiles à évaluer suivant la qualité de la machine utilisée. 0,57721... semble assuré et notre encadrement permet d'être rassuré quant à la validité des calculs. Effectivement, la valeur de C, à 10-20 près est :

C = 0,57721566490153286060...


© Serge Mehl - www.chronomath.com