ChronoMath, une chronologie des MATHÉMATIQUES
à l'usage des professeurs de mathématiques, des étudiants et des élèves des lycées & collèges

Formule de Wallis pour le calcul approché de π
      programmation récursive               
preuve de la formule

On sait, ou on admettra, que :

Au lieu d'un procédé itératif, recopie vers le bas, on se propose ici d'utiliser une méthode fonctionnelle : le résultat apparaît dans une cellule bien précise en fonction de n : il y a alors des appels récursifs dans certaines cellules que nous allons étudier :

Dans les Options, on choisit Mode de Calcul et on coche l'item itération permettant d'autoriser les références circulaires, c'est à dire l'appel d'une cellule à elle-même :

Tableur & récursion

Demandons là, 5000 itérations. Il s'agira ensuite de lancer les calculs de façon manuelle afin de pouvoir correctement initialiser nos calculs (Excel va très vite et est très pressé !). Pour ce faire

= Programme =

A

B

C

D

E

1

compteur n

2n

(2n)^2

Pi/2

Pi

2

=SI(d=0;0;A2+1)

=2*A2

=B2*B2

=SI(d=0;1;D2*C2/(C2-1))

=2*D2

3

drapeau

4

0

= Après exécution : mise à 1 du drapeau =

A

B

C

D

E

1

compteur n

2n

4n^2

Pi/2

Pi

2

6272

12544

157351936

1,570733722

3,141467443

3

drapeau

4

1

On obtient 3,14 pour n = 500 , et 3,1415 vers n = 8500. Ne procédant pas par encadrement, on ne peut être assuré d'une bonne convergence car le propre de l'ordinateur est de faire des erreurs d'arrondi pouvant se propager de façon catastrophique ! Le procédé ne peut pas être stable pour de grandes valeurs de n car 4n2 et 4n2 + 1 sont alors sensiblement égaux pour la machine et par suite le calcul va "piétiner"...

Vers un calcul sûr et plus précis du nombre π :


© Serge Mehl - www.chronomath.com